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Presentation of MorphoLeaf

The MorphoLeaf application allows you to extract the contour of multiple

leaf  images  and  identify  their  biologically-relevant  landmarks.  These

landmarks  are  then  used  to  quantify  morphological  parameters  of

individual leaves and to reconstruct average leaf shapes. 

The MorphoLeaf plug-in is subdivided into 7 modules, each performing a

specific task within a global process. You may either go through the whole

process step by step, or stop the process at a given step and restart later. 
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Installation of MorphoLeaf

Go to the MorphoLeaf web site at http://morpholeaf.versailles.inra.fr/ to get

the latest version of MorphoLeaf and installation instructions. 
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Some advice to start with optimal leaf images

- Place a single leaf horizontally in each image, centering the blade

in the middle and leaving a clear homogenous background around it

(i.e. free of other leaves parts and/or debris).
- Orient all  leaves in the same project similarly.  For example,  all

leaves oriented with their petiole on the left and tip on the right.
- Maximize as much as possible the contrast between the leaf and

the background. Try different backgrounds if possible.
- Optimize the resolution of your picture. For most leaves, 1000 pixels

along the main leaf axis are enough. You may lower the resolution for

leaves with a simple structure and increase it for leaves that are highly

dissected. 
- Keep a record of the calibration in size of your pictures. If possible, keep

the  same  magnification  for  all  your  pictures.  This  will  simplify  the

treatment of  your pictures but  is  not  compulsory as MorphoLeaf  can

handle pictures with different magnifications in the same stack.
- Treat  different  genotype,  growth  conditions,  or  species  as  different

projects assembling them into different stacks (see section 2).
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1. Importing leaf images into Free-D

Here you will import your pictures into a Free-D stack that will contain as

many slices as the number of pictures you have imported.

A  comprehensive  guide  for  the  use  of  the  Free-D  software  can  be

downloaded from http://free-d.versailles.inra.fr/ .

1.1. Before taking your leaf pictures consult the section “Some advice to

start with optimal leaf images”. Make sure that your pictures are in

.tif. If not, you can convert them using softwares like ImageJ. Free-D

and  MorphoLeaf  accept  either  Grayscale  (8  bits)  or  RGB (24  bits)

images.
1.2. Start Free-D by double clicking the Free-D icon.
1.3. In the  File  menu, click  New stack to open the  New stack dialogue

window.
1.4. In the  New stack window, fill-in the  Stack name, the  Length unit

and the Pixel width fields. If your pictures have different calibrations

you will have the opportunity to add this information later on (1.9).

You don’t need to modify the slice spacing and aspect ratio fields and

you can leave the store absolute path to images unchecked. 
1.5. Click  the  Add button to  open the  Select  image files window from

which you can  choose the images you want to analyze.  Validate

your choice by clicking  Open in the  Select image files window and

clicking Done in the New stack window. 
1.6. The pictures will appear as different slices within a single stack. You

can switch between single slice view and panorama view by clicking

the   and  icons at the top of the Free-D window. 
1.7. You can navigate through the stack to check the different pictures by

clicking on their  name in the  Slices part  of  the  Free-D window or

using the  navigation icons at the top of the Free-D window
1.8. You can zoom in and out by clicking the   and   icons and resize to

the full window using the   icon. Once you have zoomed-into your

picture you can change the local  view using the  Overview window

active  via the   icon,  using  the  scroll  icons      ,  or  by
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maintaining  the  space  bar  pressed  and  moving  the  mouse  while

clicking. 
1.9. You  can  switch  between  views  of  only  the  leaf  picture,  only  the

segmented items you will create or both by clicking on or 
1.10. To change the calibration of a single picture, select the picture by

clicking on its name in the  Slices part of the  Free-D window, select

Edit > Slice properties and in the Slice properties window change

the Pixel width value and validate your choice by clicking on Apply.
1.11. Save your stack by clicking the   icon.  This  will  create a STACK

DESCRIPTION FILE (.sdf) that contains the data related to your picture

stack. 
1.12. You can close your stack at anytime clicking on   or in the  File

menu, clicking Close stack.
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2.  Create a new MorphoLeaf project or load an

existing MorphoLeaf project

Here you will create a new MORPHOLEAF FILE (.mlf) or open an existing

MORPHOLEAF  FILE  (.mlf).  The  MORPHOLEAF  FILE  (.mlf)  contains  the

metadata associated with the leaf pictures.

2.1. You can continue directly from step 1.9 with an already open .sdf file

(skip to 2.3). 
2.2. Alternatively, you can launch a new session of Free-D and open an

existing .sdf file containing your pictures by clicking the  icon or by

clicking  File  > Open stack,  selecting your file  of  interest in  the

Open stack window.
2.3. In the Plugins menu start the  MorphoLeaf plugin. This will open a

MorphoLeaf window in the Project Manager module. 
2.4. To start a new project, click New Project and fill the fields in the New

project dialogue window (no field is compulsory).
Select  the  Venation  Type of  the  leaves:  choose   for  pinnate

venation or   for palmate venation. If you choose palmate, the part

of the leaf surrounding its tip will be included in the analysis while if

you choose pinnate it will be excluded.
Click the   icon and in the  Find directory window set the location

where  the  .mlf  file  containing  the  metadata  of  the  project  will  be

saved and then click Choose. Validate by clicking Done.
2.5. To work on an existing project, click Open Project to open the Open

project window in which you can select the .mlf file you want. Validate

your choice by clicking Open. 
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3. Extraction of the leaf contour and positioning

of the petiole/blade junction

Here you will automatically extract the contours of the leaves in all the

slices  of  the  stack  and have the  opportunity  to  manually  edit  them if

necessary.  You  will  also  have  to  set  manually  two  landmarks

corresponding to the petiole/blade junction.

3.1. You can continue directly from the  2.4 step with an ongoing project

and skip to 3.3. 

3.2. Alternatively, you can launch a new session of Free-D and Open an

existing MorphoLeaf project or create a new one as described in

section  2.  Create  a  new  MorphoLeaf  project  or  load  an  existing

MorphoLeaf project. 

3.3. Go  to  the  leaf  contour  extraction  module in  the  MorphoLeaf

window,  by  clicking  the  Extract  Contour icon on  the  left  of  the

MorphoLeaf window. 

3.4. Select  the type of  background of  your picture in the  Background

Selector,  and  the  channel  which  will  be  used  to  extract  the  leaf

contour in the Channel Selector. Choose a  Fidelity value, ranging

from 10 to 100. A high fidelity value will make a contour that follows

all the small details of the leaf margin and is recommended for very

sharp  pictures,  while  a  low  fidelity  value  will  lead  to  a  smoother

contour and is more suitable for noisy pictures. It  is  recommended

here  to  test  different  settings  to  identify  those  generating  leaf

contours that require the fewer editions. 

3.5. Click Process to extract the leaf contours. This takes a few seconds

to a few minutes depending on the number and size of the slices in

the stack and will generate the leaf contour on each image that will

appear as a thin blue line . You can switch the views between the
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leaf,  the leaf contour and both of them as described in  1.9.  After

contour  extraction,  a  message  appears  reminding  you  to  add  two

landmarks on each leaf corresponding to the blade-petiole junctions

(see 3.7).

3.6. You now have the opportunity to edit the leaf contour if necessary. You

can check the quality of the extracted contours by navigating through

the slices, zoom in and out of the picture (see 1.6. to 1.8.). To edit the

contours: 

3.6.1. Select the leaf contour by clicking on it: all the points of

the  contour  will  become  visible  as  small  black  squares.

Alternatively,  right-click anywhere around the leaf to open a

contextual dialogue window and click Select > Contours
3.6.2.You may want to start by reducing the number of points of the

contour to a manageable size, but be careful not to reduce it too

much  as  it  may  lead  to  smoothening  of  the  leaf  contour.

Typically  300-500 points  is  optimal,  but  this  depends  on leaf

complexity  and  size.  To  reduce the  number  of  points,  right-

click to open a contextual dialogue window, from which you can

select the  Edit >  Resample to open the  Contour resampling

window.  Alternatively,  you  can  open  the  Contour  resampling

window  by  pressing  R on  your  keyboard.  In  the  Contour

resampling window  you  can  change  the  number  of  points

(called Vertices) and validate by clicking OK. 
3.6.3. You can manually edit any feature in a .sdf file. For this, choose

the feature you want to edit, here the leaf contour, either by

clicking it or click right to open a contextual dialogue window,

from which you can select the Edit > Select. Next, click right

to open again the contextual dialogue window and choose Edit

>  Edit  points to  open  the  Vertex  edition  tools window.

Alternatively, you can open the Vertex edition tools window by

pressing E on your keyboard. To move a point, select the Move

points icon , click on a point and drag it with the mouse. To

insert a new point, select the Insert points icon  and click on
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the leaf contour where you want to insert the point. To remove a

point,  select the  Delete points icon   and click  a point  to

remove  it  (large  numbers  of  points  can  also  be  deleted  by

dragging  the  mouse  while  keeping  the  mouse  left  button

pressed-down).  At  the  end of  the  edition  process  select  End

edition or  press  Escape on  your  keyboard.  Save ( )  the

changes made in the .sdf file.

3.7. Once you have checked and/or edited the leaf contours you have to

define the junction between the petiole and the blade by positioning

two landmarks along the leaf contour. For this right-click to open the

contextual dialogue window and select  Draw >  Manual >  Petiole.

Click successively on the two positions along the leaf contour that

correspond to petiole/blade junction to draw the landmarks   and

validate by pressing Return on your keyboard. These landmarks will

be used to define the blade and the petiole parts on the leaf contour.

If you need to edit these landmarks proceed as described in  3.6.3.

Repeat steps 3.6 to 3.7 for every slice.
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4. Extraction of the leaf tip and teeth sinuses

Here  you  will  identify  the  sinuses  on  the  leaf  contours  and have  the

opportunity to manually edit them if necessary. In the same step, the apex

of the leaf will be automatically identified.

4.1. You can continue directly from step 3.7 with an ongoing project and

skip to 4.3.

4.2. Alternatively, launch a new session of Free-D, open an existing .sdf

file containing your pictures by clicking the  icon or by clicking the

File > Open stack, selecting your file of interest in the Open stack

window. Open an existing MorphoLeaf project or create a new

one as described in section  2. Create a new MorphoLeaf project or

load an existing MorphoLeaf project.  At this step, your .sdf file should

contain  validated  leaf  contours   and  petiole/blade  junction

landmarks . If this is not the case proceed as described in section 3.

Extraction of the leaf contour  . 

4.3. Go to the  sinus extraction module by clicking the  Extract Sinus

icon on the left of the MorphoLeaf window.

4.4. Sinuses are detected based on variations of the local curvature on the

leaf contour. in a two-step procedure: first portions of the contour that

contain a sinus are determined as continuous intervals with only local

curvature values below a user-defined threshold, second within each

of  the  obtained  intervals,  the  point  with  the  minimal  curvature  is

selected  as  a  sinus.  You  can  adjust  two  parameters.  Half

Neighborhood corresponds to the number of pixels along the leaf

contour that are used to calculate the local curvature. You may want

lower  this  parameter  to  detect  sinuses  with  a  high  frequency and

increase  it  to  detect  sinuses  with  a  low  frequency.  Maximum

Curvature Angle is the limit value of the angle that determines the

intervals containing a sinus. You may want to increase this parameter
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to detect shallow sinuses and lower it to be more stringent and detect

only sharper sinuses.  Start sinus detection by clicking  Process. You

can then navigate through the stack to check the position of sinuses

 and temporary sinus  (see below). You can test different values

and  parameters  to  find  optimal  detection  conditions  by  clicking

Process as many times as you like. Once optimal parameters have

been identified you can edit the sinuses if necessary by proceeding as

described in 3.6.3. 

4.5. After sinus detection a warning window may pop-up indicating that a

single  sinus  (that  will  appear  as  a  temporary  sinus  )  has  been

detected on one or  more slices  of  some leaves.  Note:  A  tooth  by

definition must be surrounded by two sinuses therefore on each half

leaf you must have two or more sinuses (or none if  the contour is

smooth). At this stage the pop-up window will prompt you to either

keep or delete all the temporary sinuses. If you decide to keep them

your next step is to go through the slices that have temporary sinuses

and when required, manually add a second sinus by  right-clicking

and selecting Draw > Manual > Primary sinus. If such a correction

is made, the temporary sinus will be automatically transformed into a

sinus  in later steps. If you decide not to make such a correction the

remaining single temporary sinuses will be automatically deleted in

the step 5.4; there is no need to delete them manually. 

4.6. The sinus extraction module also detects the apex of the leaf  , as

the point  farther  away from the petiole/blade junction.  You  should

check that it is properly positioned in each slice and if necessary edit

it by proceeding as described in in 3.6.3.
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5. Extraction of the teeth tips

Here you will identify the tips located between each pair of sinuses using

one of two methods. The first method, more appropriate for sharp teeth,

detects  the  point  corresponding  to  the  maximum  of  local  curvature

between two sinuses. The second method, that works better for tooth with

rounder tips, is based on the maximization of a local symmetry criterion. 

5.1 . You can continue directly from step 4.6. with an ongoing project and

skip to 5.3.

5.2. Alternatively, start Free-D, open an existing .sdf file containing your

pictures  by  clicking the   icon or  by  clicking the  File  menu and

Open stack, selecting your file of interest in the Open stack window.

Open an existing MorphoLeaf project or create a new one as

described in section  2. Create a new MorphoLeaf project or load an

existing MorphoLeaf project.  At this step, your .sdf file should contain

validated leaf contours   and petiole/blade junctions  , sinuses  

and leaf apex  landmarks. If this is not the case go back to previous

steps. 

5.3. Go to the tip extraction module by clicking the Extract Tips icon

at the left of the MorphoLeaf window.

5.4. Two  methods  are  available  to  detect  the  teeth  tips.  The  Local

Curvature Maximum method detects the point with the maximum

local  curvature  between  two  sinuses.  You  may  want  to  use  this

method  for  pointy  tips.  You  have  to  choose  the  neighborhood  on

which  the  local  curvature  is  calculated,  expressed  here  as  a

percentage  of  the  length  of  the  tooth.  The  Local  Symmetry

Maximum  method is  based on the observation that  towards their

summit,  teeth or  lobes tend to be symmetrical  and that the tip is

located along the axis of symmetry. You may want to use this method

for rather round structures. Start tip detection by clicking  Process.
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Once  finished  you  can  navigate  through  the  stack  to  check  the

location  of  the  teeth  tips  .  You  can  test  different  values  and

parameters to find optimal detection conditions by clicking  Process

as  many  times  as  you  like.  Once  optimal  parameters  have  been

identified  you  can  edit  the  sinuses  if  necessary  by  proceeding  as

described in 3.6.3. 

If single sinuses are still present on some half leaf contours, a warning

window will  pop-up.  Before  proceeding  you  should  add  sinuses  or

delete the temporary single sinuses using the procedure described in

4.5.

Note : If you choose palmate for the venation type (2.4) a tip will be

positioned at the leaf tip while none will be positioned if you select

pinnate. 
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6. Hierarchisation of the teeth

Here you will identify the hierarchical structure of teeth that is required to

properly  quantify  parameters  associated  with  the  teeth.  The aim is  to

identify and associate primary structures and the higher order structures

they  support.  Two  methods  are  available,  the  recursive  method  being

more specifically dedicated to Arabidopsis leaves and the iterative method

being more generic. 

6.1 . You can continue directly from step 5.4. with an ongoing project

6.2. Alternatively, start Free-D, open an existing .sdf file containing your

pictures  by  clicking the   icon or  by  clicking the  File  menu and

Open stack, selecting your file of interest in the Open stack window.

Open an existing MorphoLeaf project or create a new one as

described in section  2. Create a new MorphoLeaf project or load an

existing MorphoLeaf project. At this step, your .sdf file should contain

validated  leaf  contours   and  petiole/blade  junctions  ,  teeth

sinuses  and tips , and leaf apex  landmarks. If this is not the

case go back to previous steps. 

6.3. Go to the  hierarchy module by clicking the Hierarchy icon at the

left of the MorphoLeaf window. 

6.4. You can choose between two hierarchy detection methods. If you are

unsure  which  method  is  most  suitable  for  your  samples  we

recommend you test the two methods and vary the parameters. 

6.4.1. The Hierarchy Recursive Method is based on the idea that

tooth  inclination  increases  with  rank  making  this  method  well

adapted for leaves which have a rather regular, convex overall

shape  like  those  of Arabidopsis  thaliana.  The  Limit  Angle

parameter allows you to set the stringency of the detection of

the secondary structures. This parameter corresponds to the limit
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of  the  angle  at  each  sinus  with  the  two  neighboring  sinuses

under which a sinus is declared as a secondary sinus. You may

want  to  lower  the  value  of  the  limit  angle  to  have  a  more

stringent  detection  of  secondary  structures  and  increase  it  to

allow the detection of less-pronounced secondary structures. In

addition to the detection of  secondary structures,  this  method

also  recognizes  “distal  structures”  that  are  formed  in  some

Arabidopsis thaliana  leaves: whereas most of  the teeth in this

species are formed successively from the tip to the base of the

leaf,  some  teeth  may  appear  distally  to  the  first-formed  and

largest  tooth  (see  below).  If  you  want  to  detect  these  distal

structure activate the  Detect distal teeth option. These distal

structures are identified on each half blade as distal teeth to the

largest tooth. Once you have defined detection parameters press

Process to run the method. The outcome will be the change in

the labeling of some landmarks with the identification of primary

, secondary  and distal  structures. Note that some

sinuses  may  have  a  double  labeling  being  for  instance  those

located between a primary tooth and a distal tooth. You can go

back to the MorphoLeaf window and test different values for the

Limit angle factor by clicking Process as many times as you like. 

6.4.2. The  Hierarchy Iterative Method is based on the idea that

primary sinuses are more aligned with a smoothed leaf contour

than secondary sinuses. The  Stringency parameter allows you

to  set  the  stringency  of  the  detection  of  the  secondary

structures.  You may want  to  lower  the  value  of  the  tolerance

factor  to  be  less  stringent  in  the  detection  of  secondary

structures and increase it to be more stringent. Press Process to

run the method. The outcome will be the change in the labeling

of some landmarks with the determination of primary sinuses 

and tips  and secondary sinuses  and tips  . Note that here
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each landmark will have a unique labeling.  You can test different

values for the tolerance factor. 

6.4.3. If your samples have no hierarchical structure you can skip the

detection  of  the  hierarchy  by  clicking  No  hierarchy and

Process. All the structures will be defined as primary . 
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7. Extraction of quantitative leaf and teeth 

parameters

Here you will extract quantitative parameters of the leaves.

7.1 . You can continue directly from step 6.4. with an ongoing project and

skip to 7.3.

7.2. Alternatively, start Free-D, open an existing .sdf file containing your

pictures  by  clicking the   icon or  by  clicking the  File  menu and

Open stack, selecting your file of interest in the Open stack window.

Open an existing MorphoLeaf project or create a new one as

described in section  2. Create a new MorphoLeaf project or load an

existing MorphoLeaf project.  At this step, your .sdf file should contain

validated  leaf  contours   and  petiole/blade  junctions  ,  teeth

sinuses  and tips , and leaf apex  landmarks, and if necessary

the hierarchy should have been determined   and/or  . If this

is not the case go back to previous steps.

7.3. Go to the analysis module by clicking on the Analysis icon at the

left  of  the  MorphoLeaf window.  Start  the  quantification  by  clicking

Process, which generates the two quantification files containing the

quantifications  of  leaf  and teeth  parameters.  If  you wish,  you can

modify the  Prefix name of the files and their location by changing

the  Output path.  The section  10.  List  of  measures describes  the

measures performed. 
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8. Reconstruction of average shapes

Here  you  will  reconstruct  average  leaf  shapes  using  either  of  two

methods. The first method computes average shapes of leaves grouped in

successive  bins  based  on  their  blade  length  (the  bins  can  be  either

automatically  calculated  or  defined  by  the  user).  The  second  method

computes  moving  averages  (the  sampling  can  either  be  automatically

calculated or the user can define the blade length of the average shapes).

In this method, the user has to enter the neighbor rank, which defines the

contribution  of  the  different  leaf  samples  to  the  construction  of  the

average shapes. For each of  these two methods you can decide which

landmarks will be taken into account to compute the average shapes. 

8.1 . You can continue directly from step 6.4. with an ongoing project and

skip to 8.3.

8.2. Alternatively, start again Free-D, open an existing .sdf file containing

your pictures by clicking the  icon or by clicking the File menu and

Open stack, selecting your file of interest in the Open stack window.

Open an existing MorphoLeaf project or create a new one as

described in section  2. Create a new MorphoLeaf project or load an

existing MorphoLeaf project. At this step, your .sdf file should contain

validated  leaf  contours   and  petiole/blade  junctions  ,  teeth

sinuses  and tips , and leaf apex  landmarks, and if necessary

the hierarchy should have been determined   and/or  . If this

is not the case go back to previous steps. 

8.3. Go  to  the  normalization module by  clicking  the  Normalization

icon at the left of the MorphoLeaf window. 

8.4. Start by defining the parameters of the  Resampling by setting the

landmarks  that  will  be  used  to  resample  the  contours  before

performing  the  normalization.  In  addition  to  the  leaf  apex  and
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petiole/blade junctions you can also include the primary sinuses and

primary  tips  by  clicking  Primary  Sinuses and  Primary  Tips,

respectively. 

8.5. Next choose the Normalization Method you want to use.

8.5.1 To construct average shapes of  leaves grouped in successive

bins based on their blade length, click on  Based on Bins. The

bins can be automatically calculated by clicking Automatically-

defined bins and entering the Number of bins.  Alternatively,

the number and the limits of the bins can be defined by the user

by clicking  User-defined bins  and  Uploading a text file (.txt)

containing  the  size  limits  of  the  bins.  For  instance  in  the  file

below, two bins are defined, the first including the leaves with a

blade length from 200 to 500 (excluded) and the second from

500 to 1000 (excluded). Therefore two mean leaf shapes will be

generated. 

200

500

1000 

8.5.2 To construct moving average shapes of leaves click on Moving

averaging.  You  have  to  define  the  Neighbor  Rank,  which

corresponds to the number of  leaves contributing to the each

average shape. A low Neighbor Rank will lead to a low number of

leaves contributing to each average shape, which may appear

noisy.  Reciprocally,  a  high  Neighbor  Rank  will  lead  to  a  high

number  of  leaves  contributing  to  each  average  shape  and  a

smoother  overall  form.  A  text  file  named  bandwidths is

generated that containing for each average shape the bandwidth

used to take into account the leaves contributing to it. 

The  sampling  of  the  moving  average  can  be  automatically

calculated  by  clicking  Automatically-defined  sampling and

entering the Number of averages (blades). Alternatively, the

number  and  blade  lengths  of  the  average  shapes  to  be
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generated can be defined by the user by clicking User-defined

target lengths  and  Uploading a text file (.txt) containing the

blade  lengths  of  the  average  shapes.   For  instance,  if  the

following file is uploaded, 2 mean shapes with a blade length of

300 and 700 will be generated. 

300

700 

8.6. You can set the  Output parameters by defining the  Output path

where the files will  be saved. Click  Process to generate the mean

shapes,  which  depending  on  the  method  used  may  take  a  few

minutes. After the process is finished the generated mean shapes will

be grouped in a new .sdf file that can be viewed in Free-D, and in

multiple  .cv  files  that  can  be viewed with  the  Sviewer  application

(http://free-d.versailles.inra.fr/html/freed.html - download). 
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9. List of landmarks. 

Contour

Petiole = blade/petiole junction

Apex = blade apex

Primary sinus

Temporary sinus

Primary tip

Secondary sinus

Secondary tip

Primary distal sinus

Primary distal tip
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10. List of measures 

Blade_Length

Blade_Width (BB)

Blade_Width(IS)

Blade_Area

Blade_Perimeter

Petiole_Width

Upper_Teeth_Number

Lower_Teeth_Number
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Total_Teeth_Number

Tooth_Position

Tooth_Width

Tooth_Height (latitude)

Tooth_Length (median)

Tooth_Area

Tooth_Perimeter

Tooth_Position_From_The_Tip

Tooth_Position_From_The_Base
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